import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?ms)(RPA\\s1:).+?Initiator\\sID:\\s(?<RPA1Initiator>[^ ]*)";
final String string = "SITE_VPLEX: \n"
+ " RPAs: \n"
+ " RPA 1: \n"
+ " Version: 4.1.SP1.P1(h.167)\n"
+ " WAN IP: 000.000.000.000\n"
+ " RPA LAN IPv4: 000.000.000.000\n"
+ " RPA LAN IPv6:N/A\n"
+ " iSCSI interface IPs: None\n"
+ " Interfaces: \n"
+ " Type: FC\n"
+ " Initiator ID: 50012481006bexxx\n"
+ " Type: FC\n"
+ " Initiator ID: 50012481006bexxx\n"
+ " Type: FC\n"
+ " Initiator ID: 50012481006bexxx\n"
+ " Type: FC\n"
+ " Initiator ID: 50012481006bexxx\n"
+ " Hardware details: \n"
+ " Hardware type: Intel Corporation S2600GZ GEN5\n"
+ " Adapter type: 2564\n"
+ " Vendor: Intel Corporation\n"
+ " Hardware Serial ID: FC6RP133000229_00000000002_FFF\n"
+ " Hardware Platform: Intel Corporation S2600GZ GEN5\n"
+ " Amount of memory: 16269416 KB\n"
+ " Number of CPUs: 12\n"
+ " RPA 2: \n"
+ " Version: 4.1.SP1.P1(h.167)\n"
+ " WAN IP: 000.000.000.000\n"
+ " RPA LAN IPv4: 000.000.000.000\n"
+ " RPA LAN IPv6:N/A\n"
+ " iSCSI interface IPs: None\n"
+ " Interfaces: \n"
+ " Type: FC\n"
+ " Initiator ID: 50012481006bdxxx\n"
+ " Type: FC\n"
+ " Initiator ID: 50012481006bdxxx\n"
+ " Type: FC\n"
+ " Initiator ID: 50012481006bdxxx\n"
+ " Type: FC\n"
+ " Initiator ID: 50012481006bdxxx\n"
+ " Hardware details: \n"
+ " Hardware type: Intel Corporation S2600GZ GEN5\n"
+ " Adapter type: 2564\n"
+ " Vendor: Intel Corporation\n"
+ " Hardware Serial ID: FC6RP133000135_0000000000_FFF\n"
+ " Hardware Platform: Intel Corporation S2600GZ GEN5\n"
+ " Amount of memory: 16269416 KB\n"
+ " Number of CPUs: 12";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}