# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:|shareId=^)\d{19}"
test_str = ("https://m.tiktok.com/h5/share/usr/6641141594707361797.html\n"
"https://m.tiktok.com/v/6749869095467945218.html\n"
"https://www.tiktok.com/@cchelseameow/video/6751181801206729990\n"
"https://www.tiktok.com/embed/6567659045795758085\n"
"https://www.tiktok.com/share/user/6567659045795758085\n"
"https://www.tiktok.com/trending?shareId=6744531482393545985")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.