import re
regex = re.compile(r"<label .*?>(.*?)<\/label>")
test_str = ("<label class=\"s-nav right\" for=\"s-22\">simply</label>\n"
"<label class=\"s-nav left\" for=\"s-21\">dummy</label>\n"
"<label class=\"s-nav right\" for=\"s-23\">text</label>\n"
"<label class=\"s-nav left\" for=\"s-22\">of the printing</label>\n"
"<label class=\"s-nav right\" for=\"s-24\">and typesetting</label>\n"
"<label class=\"s-nav left\" for=\"s-23\">industry</label>\n"
"<label class=\"s-nav right\" for=\"s-25\">Lorem Ipsum</label>\n"
"<label class=\"s-nav left\" for=\"s-24\">Ipsum</label>")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)