$re = '/\/.*(?=\/.*?)/';
$str = 'www.test.com /en/en_gb/ path
www.test.com /en/ path
www.test.com /es/ path
www.test.com /es/es_es/ path';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);