re = /^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[!@#$%^&*()_\-+=[\]{}|'])[A-Za-z0-9!@#$%^&*()_+\-=[\]{}|']{8,20}$/m
str = 'abcABC123!
abc/ABC123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end