import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:Second)?Latitude:(-?\\d+(?:\\.\\d+)?)(?:Second)?Longitude:(-?\\d+(?:\\.\\d+)?)";
final String string = "WorkLocationBoundingBox\n"
+ "Latitude:30.556555Longitude:-97.659824\n"
+ "SecondLatitude:30.569138SecondLongitude:-97.650855";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}