$re = '/^(?i)(?:[b-z]*a){3}[a-z]*$/m';
$str = 'Anagram
Assassination
Abaca';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);