$re = '/^(?=(?!.*\btwo\b)|(?!.*\bthree\b)).*$/m';
$str = 'one two three four
one two three
one two
one three
four
one two four three';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);