re = /^(?=.*\btwo\b)(?=.*\bthree\b)(*SKIP)(*F)|^.*$/m
str = 'one two three four
one two three
one two
one three
four
one two four three'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end