re = /(?:^|\b)(?<number>(?:\d+|\d{1,3}(?:,\d{3})+)(?:\.\d+)?)(?<replace> ?|&[^;]{2,7};)(?<dimensions>(?<mathjax>\$[^\n\$]+\$)|(?<unit>(?<si>(?!as)(?:[QRYZEPTGMkhdcmµnpfazyrq]|da)?(?:mol|cd|Hz|Pa|Wb|lm|lx|Bq|Gy|Sv|kat|[mgsAKNJWCVFΩSTHL]))|(?<imperial>mil|P|in|ft|yd|mi|le|ftm|nmi|oz|lbs?|t|tsp|tbsp|c|fl oz|pt|qt|gal|(?:sq|cu) ?(?:in|ft|yd|mi)|ft-lbf?|lbf?-ft|deg|Btu|psi|Ly)|(?<common>mph|kph|rad|sr)|(?<binary>(?:(?:[KMGTPEZY])i?)?B)))(?=\b|$| |[.,:;()\[\]{}=\/*+—–-])/m
str = 'I have a 30 $m^2$ pumpernickle
More precisely it\'s 29.87$m^2$.
Traveling over 4,000 km, to where once there was
...in the year 2016 as a new method of...
He crashed at 50mph
They collided at speeds of over 200m/s
The reading is 2kHz.
The range is 20kHz–1MHz (1,000.3 kHz).
Just 4M words at 30MB.'
subst = '$<number> $<dimensions>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result