$re = '/^(?:(?!\b(sample|test)\b).)*$/m';
$str = 'this is a test case
this is a testing area';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);