import re
regex = re.compile(r"([\s\S]+)\s*primary\s+key\s*\(\s*`([a-z]\w*)`\s*\)\s*(,\s*unique\s+key\s+uniq_\w+\s*\(`([a-z]\w*)`\))?(,\s*key\s+idx_\w+\s*\((\s*,?\s*`([a-z]\w*)`\s*)+\)\s*)+", flags=re.IGNORECASE)
test_str = ("`id` INT (11) UNSIGNED NOT NULL AUTO_INCREMENT COMMENT 'primary',\n"
"`stu_name` VARCHAR (10) NOT NULL DEFAULT '' COMMENT 'username',\n"
"`stu_class` VARCHAR (10) NOT NULL DEFAULT '' COMMENT 'class',\n"
"`stu_num` INT (11) NOT NULL DEFAULT '0' COMMENT 'study number',\n"
"`stu_score` SMALLINT UNSIGNED NOT NULL DEFAULT '0' COMMENT 'total',\n"
"`tuition` DECIMAL (5, 2) NOT NULL DEFAULT '0' COMMENT 'fee',\n"
"`phone_number` VARCHAR (20) NOT NULL DEFAULT '0' COMMENT 'mobile',\n"
"`create_time` TIMESTAMP NOT NULL DEFAULT CURRENT_TIMESTAMP COMMENT 'record created time',\n"
"`update_time` TIMESTAMP NOT NULL DEFAULT CURRENT_TIMESTAMP COMMENT 'record updated time',\n"
"`status` TINYINT NOT NULL DEFAULT '1' COMMENT 'some comment',\n"
"PRIMARY KEY (`id`),\n"
"UNIQUE KEY uniq_stu_num (`stu_num`),\n"
"KEY idx_stu_score (`stu_score`),\n"
"KEY idx_update_time_tuition (`update_time`, `tuition`)")
subst = "\\2"
result = regex.sub(subst, test_str)
if result:
print(result)