#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:.*?Descritivo ){2}(.*)"
Local $sString = "Nota de Lançamento\r\n\r\nNr.Doc. 11872640706\r\n\r\n \r\n\r\nConta Depósitos à Ordem nº: 2029241\r\nMoeda da Conta: EUR\r\nIBAN: PT50003300000000202924105 VIAGENS ABREU SA\r\nNº Contribuinte: 500297177 PC TRINDADE 142 4 ANDAR\r\n4000-539 PORTO\r\n\r\nCE04475/01\r\nGestor de Cliente\r\nCARLOS ALBERTO OLIVEIRA\r\nTel: 211136566\r\nAV PROF DR CAVACO SILVA 30 EDF 2 0 B\r\nTAGUS PARK\r\nFax: 211136989\r\ne-mail: CARLOS.MAGALHAESOLIVEIRA@MILLENNIUMBCP.PT\r\n\r\nLisboa, 31 de agosto de 2020\r\n\r\nExmos. Senhores,\r\nInformamos que, relativamente à conta de Depósitos à Ordem acima mencionada, efetuámos o(s) seguinte(s) movimento(s):\r\n\r\nOperação: TRANSFERÊNCIA PERMANENTE DE FUNDOS A DÉBITO\r\nTipo de Operação: Ordem Permanente Intrabancária (para conta do Millennium bcp)\r\nNossa Referência: TNP200731131431O9210/0001\r\n\r\nDados da Operação Moeda\r\n\r\nMontante da Transferência 2.134,98 EUR\r\nDescritivo da Transferência na Conta a Debitar TRF P/ MADALENA FRANCO DE SOUSA E FILHOS\r\nIBAN da Conta do Destinatário PT50003300004523630143205\r\nInstituição de Crédito de Destino BANCO COMERCIAL PORTUGUES, SA\r\nDescritivo VIAGENS ABREU, S.A. . 202008\r\nPeriodicidade da Transferência MENSAL\r\nData de Validade da Instrução Permanente 2020/12/31\r\nData do Movimento 2020/08/31\r\nData Valor da Operação 2020/08/31\r\n\r\nBanco Comercial Português, S.A., sociedade aberta - Sede: Praça D. João I, 28, Porto, Capital Social: Euros 4.725.000.000,00 - Matric. na Cons. do Reg. Com. do Porto, com o nº único de matrícula e de identificação fiscal 501 525 882\r\nCom os nossos melhores cumprimentos,\r\n\r\n \r\nBanco Comercial Português, S.A.\r\n\r\n(Documento Processado por Computador) Pág. 1/1 \r\n\r\n707 50 24 24\r\nwww.millenniumbcp.pt Atendimento personalizado 24H"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")