$re = '/(\w+\.\w+)(?=\?)/';
$str = 'http://www.google.com/joao.pedro?a=b';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);