import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(#\\S+(?: [^\\s=\"]+=\"[^\"]+\")+),(.*)\\s(.*)";
final String string = "#EXTINF:-1 tvg-id=\"ChannelName\" tvg-name=\"|FR| Channel\" tvg-logo=\"http://logo\" timeshift=\"1\" group-title=\"|FR| FrenchChannel\",|FR| Channel Fullname\n"
+ "URL";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}