$re = '/(\[(\d+)\])+(?=[:.](\s|$)|\n)/m';
$str = 'sometext [1].
sometext [1].
sometext [1]
sometext [1] a
sometext [1].a
sometext [1]. a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);