$re = '/([^_]*)(.*)/m';
$str = '{Productnr}_LEI1.JPG';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);