#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:(?:\s+<PackageVersion Include="([^"]+)".*)|.*)"
Local $sString = "<Project>" & @CRLF & _
" <!-- Workaround https://github.com/dependabot/dependabot-core/issues/8490 -->" & @CRLF & _
" <!-- This file gets imported for out-of-tree test runs also where eng/Versions.props isn't" & @CRLF & _
" available -->" & @CRLF & _
" <Import Project="eng/Versions.props" Condition="'$(MajorVersion)' == '' and Exists('eng/Versions.props')" />" & @CRLF & _
" <PropertyGroup>" & @CRLF & _
" <ManagePackageVersionsCentrally>true</ManagePackageVersionsCentrally>" & @CRLF & _
" <TestcontainersPackageVersion>3.9.0</TestcontainersPackageVersion>" & @CRLF & _
" </PropertyGroup>" & @CRLF & _
" <ItemGroup>" & @CRLF & _
" <!-- AWS SDK for .NET dependencies -->" & @CRLF & _
" <PackageVersion Include="AWSSDK.CloudFormation" Version="3.7.308.18" />" & @CRLF & _
" <PackageVersion Include="AWSSDK.SQS" Version="3.7.301.26" />" & @CRLF & _
" <PackageVersion Include="AWSSDK.SimpleNotificationService" Version="3.7.301.61" />" & @CRLF & _
" <PackageVersion Include="AWSSDK.Core" Version="3.7.304.23" />" & @CRLF & _
" <PackageVersion Include="AWSSDK.Extensions.NETCore.Setup" Version="3.7.301" />" & @CRLF & _
" <PackageVersion Include="AWS.Messaging" Version="0.9.1" />" & @CRLF & _
" <PackageVersion Include="OpenTelemetry.Instrumentation.AWS" Version="1.1.0-beta.4" />" & @CRLF & _
" <PackageVersion Include="OpenTelemetry.Extensions.AWS" Version="1.3.0-beta.1" />" & @CRLF & _
" <!-- Azure SDK for .NET dependencies -->" & @CRLF & _
" <PackageVersion Include="Azure.AI.OpenAI" Version="1.0.0-beta.17" />" & @CRLF & _
" <PackageVersion Include="Azure.Data.Tables" Version="12.8.3" />" & @CRLF & _
" <PackageVersion Include="Azure.Extensions.AspNetCore.Configuration.Secrets" Version="1.3.1" />" & @CRLF & _
" <PackageVersion Include="Azure.Identity" Version="1.12.0" />" & @CRLF & _
" <PackageVersion Include="Azure.Messaging.EventHubs.Processor" Version="5.11.3" />" & @CRLF & _
" <PackageVersion Include="Azure.Messaging.ServiceBus" Version="7.17.5" />" & @CRLF & _
" <PackageVersion Include="Azure.Search.Documents" Version="11.5.1" />" & @CRLF & _
" <PackageVersion Include="Azure.Messaging.WebPubSub" Version="1.3.0" />" & @CRLF & _
" <PackageVersion Include="Azure.Security.KeyVault.Secrets" Version="4.6.0" />" & @CRLF & _
" <PackageVersion Include="Azure.Storage.Blobs" Version="12.20.0" />" & @CRLF & _
" <PackageVersion Include="Azure.Storage.Queues" Version="12.18.0" />" & @CRLF & _
" <PackageVersion Include="Microsoft.Azure.AppConfiguration.AspNetCore" Version="7.2.0" />" & @CRLF & _
" <PackageVersion Include="Microsoft.Azure.Cosmos" Version="3.41.0" />" & @CRLF & _
" <PackageVersion Include="Microsoft.Azure.SignalR" Version="1.25.2" />" & @CRLF & _
" <PackageVersion Include="Microsoft.Extensions.Azure" Version="1.7.4" />" & @CRLF & _
" <!-- Azure Management SDK for .NET dependencies -->" & @CRLF & _
" <PackageVersion Include="Azure.Provisioning" Version="0.3.0" />" & @CRLF & _
" <PackageVersion Include="Azure.Provisioning.AppConfiguration" Version="0.2.0" />" & @CRLF & _
" <PackageVersion Include="Azure.Provisioning.ApplicationInsights" Version="0.1.0" />" & @CRLF & _
" <PackageVersion Include="Azure.Provisioning.CognitiveServices" Version="0.2.0" />" & @CRLF & _
" <PackageVersion Include="Azure.Provisioning.CosmosDB" Version="0.1.0" />" & @CRLF & _
" <PackageVersion Include="Azure.Provisioning.EventHubs" Version="0.1.0" />" & @CRLF & _
" <PackageVersion Include="Azure.Provisioning.KeyVault" Version="0.2.0" />" & @CRLF & _
" <PackageVersion Include="Azure.Provisioning.OperationalInsights" Version="0.2.0" />" & @CRLF & _
" <PackageVersion Include="Azure.Provisioning.PostgreSql" Version="0.1.0" />" & @CRLF & _
" <PackageVersion Include="Azure.Provisioning.Redis" Version="0.2.0" />" & @CRLF & _
" <PackageVersion Include="Azure.Provisioning.Resources" Version="0.2.0" />" & @CRLF & _
" <PackageVersion Include="Azure.Provisioning.Search" Version="0.1.0" />" & @CRLF & _
" <PackageVersion Include="Azure.Provisioning.ServiceBus" Version="0.1.0" />" & @CRLF & _
" <PackageVersion Include="Azure.Provisioning.SignalR" Version="0.2.0" />" & @CRLF & _
" <PackageVersion Include="Azure.Provisioning.Sql" Version="0.1.0" />" & @CRLF & _
" <PackageVersion Include="Azure.Provisioning.Storage" Version="0.2.0" />" & @CRLF & _
" <PackageVersion Include="Azure.Provisioning.WebPubSub" Version="0.1.0-beta.1" />" & @CRLF & _
" <!-- ASP.NET Core dependencies -->" & @CRLF & _
" <PackageVersion Include="Microsoft.AspNetCore.Authentication.Certificate" Version="$(MicrosoftAspNetCoreAuthenticationCertificatePackageVersion)" />" & @CRLF & _
" <PackageVersion Include="Microsoft.AspNetCore.Authentication.OpenIdConnect" Version="$(MicrosoftAspNetCoreAuthenticationOpenIdConnectPackageVersion)" />" & @CRLF & _
" <PackageVersion Include="Microsoft.AspNetCore.OpenApi" Version="$(MicrosoftAspNetCoreOpenApiPackageVersion)" />" & @CRLF & _
" <PackageVersion Include="Microsoft.AspNetCore.OutputCaching.StackExchangeRedis" Version="$(MicrosoftAspNetCoreOutputCachingStackExchangeRedisPackageVersion)" />" & @CRLF & _
" <PackageVersion Include="Microsoft.Extensions.Caching.StackExchangeRedis" Version="$(MicrosoftExtensionsCachingStackExchangeRedisPackageVersion)" />" & @CRLF & _
" <PackageVersion Include="Microsoft.Extensions.Diagnostics.HealthChecks.EntityFrameworkCore" Version="$(MicrosoftExtensionsDiagnosticsHealthChecksEntityFrameworkCorePackageVersion)" />" & @CRLF & _
" <PackageVersion Include="Microsoft.Extensions.Diagnostics.HealthChecks" Version="$(MicrosoftExtensionsDiagnosticsHealthChecksPackageVersion)" />" & @CRLF & _
" <PackageVersion Include="Microsoft.Extensions.Features" Version="$(MicrosoftExtensionsFeaturesPackageVersion)" />" & @CRLF & _
" <!-- AspNetCore.HealthChecks dependencies (3rd party packages) -->" & @CRLF & _
" <PackageVersion Include="AspNetCore.HealthChecks.Azure.Data.Tables" Version="8.0.1" />" & @CRLF & _
" <PackageVersion Include="AspNetCore.HealthChecks.Azure.KeyVault.Secrets" Version="8.0.1" />" & @CRLF & _
" <PackageVersion Include="AspNetCore.HealthChecks.Azure.Storage.Blobs" Version="8.0.1" />" & @CRLF & _
" <PackageVersion Include="AspNetCore.HealthChecks.Azure.Storage.Queues" Version="8.0.1" />" & @CRLF & _
" <PackageVersion Include="AspNetCore.HealthChecks.AzureServiceBus" Version="8.0.1" />" & @CRLF & _
" <PackageVersion Include="AspNetCore.HealthChecks.Kafka" Version="8.0.1" />" & @CRLF & _
" <PackageVersion Include="AspNetCore.HealthChecks.MongoDb" Version="8.0.1" />" & @CRLF & _
" <PackageVersion Include="AspNetCore.HealthChecks.MySql" Version="8.0.1" />" & @CRLF & _
" <PackageVersion Include="AspNetCore.HealthChecks.NpgSql" Version="8.0.1" />" & @CRLF & _
" <PackageVersion Include="AspNetCore.HealthChecks.Rabbitmq" Version="8.0.1" />" & @CRLF & _
" <PackageVersion Include="AspNetCore.HealthChecks.Redis" Version="8.0.1" />" & @CRLF & _
" <PackageVersion Include="AspNetCore.HealthChecks.SqlServer" Version="8.0.2" />" & @CRLF & _
" <!-- efcore dependencies -->" & @CRLF & _
" <PackageVersion Include="Microsoft.EntityFrameworkCore.Cosmos" Version="$(MicrosoftEntityFrameworkCoreCosmosPackageVersion)" />" & @CRLF & _
" <PackageVersion Include="Microsoft.EntityFrameworkCore.SqlServer" Version="$(MicrosoftEntityFrameworkCoreSqlServerPackageVersion)" />" & @CRLF & _
" <PackageVersion Include="Microsoft.EntityFrameworkCore.Tools" Version="$(MicrosoftEntityFrameworkCoreToolsPackageVersion)" />" & @CRLF & _
" <PackageVersion Include="Microsoft.EntityFrameworkCore.Design" Version="$(MicrosoftEntityFrameworkCoreDesignPackageVersion)" />" & @CRLF & _
" <!-- runtime dependencies-->" & @CRLF & _
" <PackageVersion Include="Microsoft.Extensions.Configuration.Abstractions" Version="$(MicrosoftExtensionsConfigurationAbstractionsPackageVersion)" />" & @CRLF & _
" <PackageVersion Include="Microsoft.Extensions.Configuration.Binder" Version="$(MicrosoftExtensionsConfigurationBinderPackageVersion)" />" & @CRLF & _
" <PackageVersion Include="Microsoft.Extensions.DependencyInjection.Abstractions" Version="$(MicrosoftExtensionsDependencyInjectionAbstractionsPackageVersion)" />" & @CRLF & _
" <PackageVersion Include="Microsoft.Extensions.Hosting.Abstractions" Version="$(MicrosoftExtensionsHostingAbstractionsPackageVersion)" />" & @CRLF & _
" <PackageVersion Include="Microsoft.Extensions.Hosting" Version="$(MicrosoftExtensionsHostingPackageVersion)" />" & @CRLF & _
" <PackageVersion Include="Microsoft.Extensions.Http" Version="$(MicrosoftExtensionsHttpPackageVersion)" />" & @CRLF & _
" <PackageVersion Include="Microsoft.Extensions.Logging.Abstractions" Version="$(MicrosoftExtensionsLoggingAbstractionsPackageVersion)" />" & @CRLF & _
" <PackageVersion Include="Microsoft.Extensions.Options" Version="$(MicrosoftExtensionsOptionsPackageVersion)" />" & @CRLF & _
" <PackageVersion Include="Microsoft.Extensions.Primitives" Version="$(MicrosoftExtensionsPrimitivesPackageVersion)" />" & @CRLF & _
" <PackageVersion Include="Microsoft.Extensions.Http.Resilience" Version="$(MicrosoftExtensionsHttpResiliencePackageVersion)" />" & @CRLF & _
" <PackageVersion Include="Microsoft.Extensions.TimeProvider.Testing" Version="$(MicrosoftExtensionsTimeProviderTestingVersion)" />" & @CRLF & _
" <!-- external dependencies -->" & @CRLF & _
" <PackageVersion Include="Confluent.Kafka" Version="2.4.0" />" & @CRLF & _
" <PackageVersion Include="Dapper" Version="2.1.44" />" & @CRLF & _
" <PackageVersion Include="DnsClient" Version="1.8.0" />" & @CRLF & _
" <PackageVersion Include="Google.Protobuf" Version="3.27.1" />" & @CRLF & _
" <PackageVersion Include="Grpc.AspNetCore" Version="2.63.0" />" & @CRLF & _
" <PackageVersion Include="Grpc.Net.ClientFactory" Version="2.63.0" />" & @CRLF & _
" <PackageVersion Include="Grpc.Tools" Version="2.64.0" />" & @CRLF & _
" <PackageVersion Include="Humanizer.Core" Version="2.14.1" />" & @CRLF & _
" <PackageVersion Include="KubernetesClient" Version="14.0.2" />" & @CRLF & _
" <PackageVersion Include="Microsoft.Data.SqlClient" Version="5.2.1" />" & @CRLF & _
" <PackageVersion Include="Microsoft.FluentUI.AspNetCore.Components" Version="4.7.2" />" & @CRLF & _
" <PackageVersion Include="Microsoft.FluentUI.AspNetCore.Components.Icons" Version="4.7.2" />" & @CRLF & _
" <PackageVersion Include="Milvus.Client" Version="2.3.0-preview.1"/>" & @CRLF & _
" <PackageVersion Include="MongoDB.Driver" Version="2.27.0" />" & @CRLF & _
" <PackageVersion Include="MongoDB.Driver.Core.Extensions.DiagnosticSources" Version="1.4.0" />" & @CRLF & _
" <PackageVersion Include="MySqlConnector.DependencyInjection" Version="2.3.6" />" & @CRLF & _
" <PackageVersion Include="MySqlConnector.Logging.Microsoft.Extensions.Logging" Version="2.1.0" />" & @CRLF & _
" <PackageVersion Include="NATS.Net" Version="2.3.0" />" & @CRLF & _
" <PackageVersion Include="Npgsql.DependencyInjection" Version="8.0.3" />" & @CRLF & _
" <PackageVersion Include="Npgsql.EntityFrameworkCore.PostgreSQL" Version="8.0.4" />" & @CRLF & _
" <PackageVersion Include="Oracle.EntityFrameworkCore" Version="8.23.40" />" & @CRLF & _
" <PackageVersion Include="Polly.Core" Version="8.4.1" />" & @CRLF & _
" <PackageVersion Include="Polly.Extensions" Version="8.4.1" />" & @CRLF & _
" <PackageVersion Include="Pomelo.EntityFrameworkCore.MySql" Version="8.0.2" />" & @CRLF & _
" <PackageVersion Include="Qdrant.Client" Version="1.10.0" />" & @CRLF & _
" <PackageVersion Include="RabbitMQ.Client" Version="[6.8.1,7.0.0)" />" & @CRLF & _
" <PackageVersion Include="StackExchange.Redis" Version="2.8.0" />" & @CRLF & _
" <PackageVersion Include="System.IO.Hashing" Version="8.0.0" />" & @CRLF & _
" <PackageVersion Include="Yarp.ReverseProxy" Version="2.1.0" />" & @CRLF & _
" <!-- Open Telemetry -->" & @CRLF & _
" <PackageVersion Include="Npgsql.OpenTelemetry" Version="8.0.3" />" & @CRLF & _
" <PackageVersion Include="OpenTelemetry.Exporter.InMemory" Version="1.9.0" />" & @CRLF & _
" <PackageVersion Include="OpenTelemetry.Exporter.OpenTelemetryProtocol" Version="1.9.0" />" & @CRLF & _
" <PackageVersion Include="OpenTelemetry.Extensions.Hosting" Version="1.9.0" />" & @CRLF & _
" <PackageVersion Include="OpenTelemetry.Instrumentation.GrpcNetClient" Version="1.9.0-beta.1" />" & @CRLF & _
" <PackageVersion Include="OpenTelemetry.Instrumentation.Http" Version="1.9.0" />" & @CRLF & _
" <PackageVersion Include="OpenTelemetry.Instrumentation.AspNetCore" Version="1.9.0" />" & @CRLF & _
" <PackageVersion Include="OpenTelemetry.Instrumentation.Runtime" Version="1.9.0" />" & @CRLF & _
" <!-- build dependencies -->" & @CRLF & _
" <PackageVersion Include="MicroBuild.Plugins.SwixBuild.Dotnet" Version="1.1.87-gba258badda" />" & @CRLF & _
" <PackageVersion Include="Microsoft.CodeAnalysis.CSharp.Workspaces" Version="4.10.0" />" & @CRLF & _
" <PackageVersion Include="Microsoft.CodeAnalysis.PublicApiAnalyzers" Version="3.3.4" />" & @CRLF & _
" <PackageVersion Include="Microsoft.DotNet.Build.Tasks.Workloads" Version="8.0.0-beta.23564.4" />" & @CRLF & _
" <PackageVersion Include="Microsoft.Signed.Wix" Version="$(MicrosoftSignedWixVersion)" />" & @CRLF & _
" <PackageVersion Include="Microsoft.DotNet.Build.Tasks.Installers" Version="8.0.0-beta.23564.4" />" & @CRLF & _
" <PackageVersion Include="System.CommandLine" Version="2.0.0-beta4.24324.3" />" & @CRLF & _
" <!-- unit test dependencies -->" & @CRLF & _
" <PackageVersion Include="bUnit" Version="1.28.9" />" & @CRLF & _
" <PackageVersion Include="JsonSchema.Net" Version="7.1.2" />" & @CRLF & _
" <PackageVersion Include="Microsoft.DotNet.RemoteExecutor" Version="$(MicrosoftDotNetRemoteExecutorPackageVersion)" />" & @CRLF & _
" <PackageVersion Include="Microsoft.DotNet.XUnitExtensions" Version="$(MicrosoftDotNetXUnitExtensionsPackageVersion)" />" & @CRLF & _
" <PackageVersion Include="Microsoft.Extensions.Diagnostics.Testing" Version="$(MicrosoftExtensionsDiagnosticsTestingPackageVersion)" />" & @CRLF & _
" <PackageVersion Include="Microsoft.NET.Runtime.WorkloadTesting.Internal" Version="$(MicrosoftNETRuntimeWorkloadTestingInternalVersion)" />" & @CRLF & _
" <PackageVersion Include="Microsoft.Playwright" Version="1.45.0" />" & @CRLF & _
" <PackageVersion Include="Swashbuckle.AspNetCore" Version="6.6.2" />" & @CRLF & _
" <PackageVersion Include="Testcontainers.MongoDb" Version="$(TestcontainersPackageVersion)" />" & @CRLF & _
" <PackageVersion Include="Testcontainers.MsSql" Version="$(TestcontainersPackageVersion)" />" & @CRLF & _
" <PackageVersion Include="Testcontainers.MySql" Version="$(TestcontainersPackageVersion)" />" & @CRLF & _
" <PackageVersion Include="Testcontainers.PostgreSQL" Version="$(TestcontainersPackageVersion)" />" & @CRLF & _
" <PackageVersion Include="Testcontainers.RabbitMq" Version="$(TestcontainersPackageVersion)" />" & @CRLF & _
" <PackageVersion Include="Testcontainers.Redis" Version="$(TestcontainersPackageVersion)" />" & @CRLF & _
" <PackageVersion Include="Testcontainers.Nats" Version="$(TestcontainersPackageVersion)" />" & @CRLF & _
" <PackageVersion Include="Testcontainers.Milvus" Version="$(TestcontainersPackageVersion)" />" & @CRLF & _
"" & @CRLF & _
" <!-- playground apps dependencies -->" & @CRLF & _
" <PackageVersion Include="Dapr.AspNetCore" Version="1.13.1" />" & @CRLF & _
" <PackageVersion Include="Microsoft.Orleans.Clustering.AzureStorage" Version="8.2.0" />" & @CRLF & _
" <PackageVersion Include="Microsoft.Orleans.Persistence.AzureStorage" Version="8.2.0" />" & @CRLF & _
" <PackageVersion Include="Microsoft.Orleans.Client" Version="8.2.0" />" & @CRLF & _
" <PackageVersion Include="Microsoft.Orleans.Server" Version="8.2.0" />" & @CRLF & _
" <PackageVersion Include="Microsoft.Orleans.Sdk" Version="8.2.0" />" & @CRLF & _
" <!-- Pinned version for Component Governance - Remove when root dependencies are updated -->" & @CRLF & _
" <PackageVersion Include="Newtonsoft.Json" Version="13.0.3" />" & @CRLF & _
" </ItemGroup>" & @CRLF & _
"</Project>"
Local $sSubst = "$1,"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)