using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+-\w+)|-+";
string substitution = @"\1";
string input = @"popcorn-flavoured---
tic-tacs
----------a----------b--";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}