re = /\d{1,6}\s(?:[A-Za-z0-9#]+\s){0,7}(?:[A-Za-z0-9#]+,)\s*(?:[A-Za-z]+\s){0,3}(?:[A-Za-z]+,)\s*[A-Z]{2}\s*\d{5}/m
str = '123 test st, test city, TT 12345'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end