$re = '/^([a-c]*[a][a-c]*[a][a-c]*)$|^([ac]*[b][ac]*[b][ac]*[b][ac]*)$/m';
$str = 'aba
abbaba
accbcccbcccbccc
cbcabcbc
abcabcabc
bbbb
acbcbc
cccccc
abcbbbb
bbbbbbb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);