$re = '/(.*)\((.*)\)/m';
$str = 'my string(100) is great
foobar(42)
asd()
nope
(1)a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);