package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(\([^)]+?\)|[^(]+)`)
var str = `I'm not surrounded by parenthesis (but I am) so what.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}