import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.{257})[A-Za-z0-9-]{3,63}\\.(?:[A-Za-z0-9-]+\\.)*[a-zA-Z]{2,6}$";
final String string = "qwerty.abcde.com\n\n"
+ "in the above \"qwerty\" should be 3-63 characters , but \"abcde\" can be any no.of characters .My pattern is applicable to next string after dot.that 3-63 rule should be applicable to only \"qwerty\" not to \"abcde\". can any one help me out.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}