$re = '/(?<=sender\s)\w*/m';
$str = 'sender match other words after';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);