const regex = /^[A-Za-z]+ [A-Za-z]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Za-z]+ [A-Za-z]+$', 'gm')
const str = `lowercase name
Unicode Namê
A Name
not
McGeorge Bundy
Three Letters Name
Alfred McCoy Tyner
McCoy Tyner
Good Name
O'Keane Name
Inv4l1d N\$m3
C00l name
,Comma Name
Following Dot,
Wrong' Quote
Wrong UpperCase
notCool Name`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}