const regex = /^(([A-Za-z]{3}\d{4}(\/\d{2}-\d{2})?)|((([A-Za-z]\d{6})|([A-Za-z]{3}\d{4}))(\/v\d{4})?))$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([A-Za-z]{3}\\d{4}(\\\/\\d{2}-\\d{2})?)|((([A-Za-z]\\d{6})|([A-Za-z]{3}\\d{4}))(\\\/v\\d{4})?))$', 'i')
const str = `X -> Digito
A -> Letra
_ -> el resto literal
CASOS:
1- AAAXXXX/XX-XX
2- AAAXXXX/VXXXX
3- AXXXXXX/VXXXX`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}