$re = '/^(?:[A-Z]{3}\d{4}(?:\/(?:\d{2}-\d{2}|V\d{4}))?|[A-Z]\d{6}(?:\/V\d{4})?)$/i';
$str = 'X -> Digito
A -> Letra
_ -> el resto literal
CASOS:
1- AAAXXXX/XX-XX
2- AAAXXXX/VXXXX
3- AXXXXXX/VXXXX';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);