$re = '/^\s*(?<date>\d{2}-\d{2}-\d{4})/m';
$str = ' 31-12-2019 Forfait 01-01-2019 - 31-12-2019 -29,00
31-12-2019Forfait 01-01-2019 - 31-12-201950,00
31-12-2019Mercedes-500,00
31-12-2019Client10 700,00
31-12-2019Comptoir17 50,00
// edge cases
31-12-2019Client 10700,00
31-12-2019Client 10-700,00
31-12-2019Client 10 700,00
31-12-2019Comptoir 1750,00
31-12-2019Comptoir 17-50,00
31-12-2019Comptoir 17 50,00
// versions related to [https://regex101.com/r/7TdghZ/1] ...
^\\s*(?<date>\\d{2}-\\d{2}-\\d{4})\\s*(?<text>[^\\s-]+(?:(?:[\\s-]*\\d{2}-\\d{2}-\\d{4})+)?)\\s*(?<amount>-*\\d+,\\d+)
// final version
^\\s*(?<date>\\d{2}-\\d{2}-\\d{4})
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);