// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[\'|\', \'|.r.n|\[\d+\]|\'\]").unwrap();
let string = "['<p class=MsoNormal>В последующих главах мы описываем концепцию DIR и методику Floortime, показываем, как проникать в мир ребенка и вводить его в наш общий мир взаимоотношений, общения и мышления. В первой части представлен новый, более точный способ определения аутизма и расстройств аутистического спектра, описано выявление их ранних признаков. Там же излагаются цели, которые ставятся при работе с детьми с расстройствами аутистического спектра и другими особенностями развития в рамках концепции DIR. Во второй части рассказывается, как семьи могут работать со своими детьми над достижением этих целей. В третьей части мы описываем методику Floortime, основанную на концепции DIR, и иллюстрируем ее применение в разных обстоятельствах. Четвертая часть рассказывает, как составить комплексный терапевтический план и каким образом школьная среда может подстраиваться под терапевтические планы. В пятой части более подробно описывается работа с отдельными проблемами. Приложения A-В дают представление об исследованиях, обосновывающих концепцию DIR.</p>', '<p class=MsoNormal>Примечание: профили развития детей в начале каждой главы — это обобщенные портреты детей, с которыми мы работали или родители которых обращались к нам с вопросами.</p>', '<div class=\"take_h1\">Часть I\\r\\n\\r\\n <br >\\r\\n Прогноз при расстройствах аутистического спектра:\\r\\n\\r\\n <br >\\r\\n мифы, факты, ранние признаки и новая концепция</div>', '<div class=\"take_h1\">Глава 1\\r\\n\\r\\n <br >\\r\\n Новое определение аутизма и наш подход к нему</div>', '<p class=MsoNormal>Аутизм — это комплексное нарушение развития, включающее проблемы с социальным взаимодействием, освоением языка и целым рядом эмоциональных, когнитивных, двигательных и сенсорных способностей, а также отставание в развитии этих способностей. Наряду с этим часто наблюдаются специфические формы поведения, например, вращение вокруг своей оси, выстраивание игрушек в ряд, бесцельное и бессмысленное повторение слов. Мы покажем далее, что подобные симптомы являются следствием более фундаментальных проблем, связанных со способностью вступать в отношения, общаться и мыслить. Кроме того, они не специфичны для аутизма. Язык, мышление и социальные навыки у ребенка с аутизмом или расстройствами аутистического спектра варьируются в зависимости от того, к какой части спектра относится его расстройство.</p>', '<p class=MsoNormal>До сих пор не вполне понятны причины и частота возникновения этого заболевания. Как уже упоминалось, согласно некоторым исследованиям, распространенность расстройств аутистического спектра доходит до 1 случая на 166 человек. Большинство исследований также отмечают резкий рост числа людей с подобными нарушениями по сравнению с уровнем десятилетней давности. Некоторые исследователи относят рост числа выявляемых случаев заболевания на счет улучшения диагностики, но многие считают, что наблюдается рост аутизма и расстройств аутистического спектра.</p>', '<div class=\"take_h1\">Множественность причин аутизма</div>', '<p class=MsoNormal>Причины роста заболеваемости, как и причины самого аутизма, неизвестны. Многие исследования подтверждают роль генетических факторов (например, подобное нарушение будет скорее наблюдаться одновременно у однояйцевых близнецов, чем у разнояйцевых). Сложилось мнение, что генетические (или, шире, биологические) факторы порождают совокупность симптомов, связанных с аутизмом или расстройствами аутистического спектра. Кроме того, принято считать, что имеют значение и факторы, связанные с иммунной системой, обменом веществ и состоянием окружающей среды. Тем не менее, единой причины, вызывающей это заболевание, до сих пор найти не удалось. Поэтому мы полагаем, что исследовать причины аутизма лучше всего с позиции так называемого кумулятивного риска, концепции множественности путей, которая полагает, что аутизм возникает в результате взаимодействия многих факторов. Генетические или пренатальные факторы, например, могут приводить к тому, что ребенок будет впоследствии подвержен стрессам от физической нагрузки, инфекционным заболеваниям или воздействию токсичных веществ. Этот новый подход к осмыслению причин признает влияние генетических факторов, но рассматривает пути развития заболевания как многоступенчатый процесс, как постепенное накопление взаимосвязанных проблем, и учитывает многочисленность их вариаций и разную степень их тяжести.</p>', '<div class=\"take_h1\">Широкий спектр проблем</div>', '<p class=MsoNormal>Для аутизма и расстройств аутистического спектра характерны проблемы с установлением контакта, формированием отношений, общением (не важно, жестами, словами или знаками) и мышлением. Эти комплексные проблемы развития могут проявляться по-разному и встречаться в разных сочетаниях. Не у каждого ребенка с одним и тем же общим диагнозом все эти проблемы обнаруживаются в одной и той же степени. Например, дети с синдромом Аспергера нередко обладают большим лексическим запасом и могут рано начинать читать, но при этом испытывают трудности с осмысленным употреблением слов в верном эмоциональном ключе. Они могут просто повторять слова или понимать их исключительно в прямом словарном значении. Кроме того, им тяжело даются отношения с другими людьми и общение, сопровождающееся эмоциями и жестами.</p>', '<p class=MsoNormal>Иной вариант проблем встречается у детей с нарушениями моторного планирования\\r\\n<a href=\"notes.php?id=46856#5\" target=\"_blank\" title=\"\\r\\n Моторное (двигательное) планирование (англ. — motor planning) — способность совершать несколько последовательных действий в определенном порядке. — Прим. ред.\\r\\n \">[5]</a>\\r\\n. Бывают дети с нарушениями речевой моторики: им сложно даются движения языка и мышц рта, чтобы произносить слова. Может казаться, что у некоторых детей с серьезными проблемами речевой и общей моторики имеются нарушения когнитивных функций и отсутствуют социальные навыки, тогда как на самом деле моторные нарушения просто не дают им проявить существующие способности и навыки. Когда мы помогаем детям, имеющим проблемы с речевой моторикой, освоить общение с помощью жестов или иных вспомогательных средств вроде компьютерной клавиатуры, часто оказывается, что они понимают гораздо больше, чем мы предполагали.</p>', '<div class=\"take_h1\">Ключевые проблемы при расстройствах аутистического спектра</div>', '<p class=MsoNormal>Аутизм и расстройства аутистического спектра характеризуются тремя ключевыми, или первичными, проблемами. Чтобы их выявить, мы задаем такие вопросы:</p>', '<p class=MsoNormal>1. Легко ли ребенок вступает в близкие и теплые отношения? Ищет ли он общества тех взрослых, с которыми ему по-настоящему комфортно, например, родителей или тех, кто о нем заботится? Если да, то демонстрирует ли он удовольствие от близких отношений?</p>', '<p class=MsoNormal>2. Общается ли ребенок с помощью жестов и эмоциональных выражений? Вовлечен ли он в постоянный поток взаимных эмоциональных сигналов вроде улыбок, нахмуриваний, кивков и иных обоюдных жестов?</p>', '<p class=MsoNormal>3. Когда ребенок начинает говорить, произносит ли он слова осмысленно? Насыщены ли эти слова эмоциями и желаниями, т. е. говорит ли он: «Мамочка, я тебя люблю» или «Я хочу тот сок», или же он произносит: «Это стол», «Это стул»?</p>', '<p class=MsoNormal>Если три эти базовые способности — установление близких отношений, постоянный обмен эмоциональными жестами и использование ранних слов или знаков с эмоциональной нагрузкой — отсутствуют, следует оценить, нет ли у ребенка признаков расстройств аутистического спектра. То, в какой мере эти три ключевых процесса или способности отклоняются от нормы для соответствующего возраста, может служить показателем (по крайней мере, первичным) степени, в которой ребенок «затронут» аутизмом.</p>']";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}