import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<h4>.*\\n";
final String string = "<h4>это заголовок</h4>вот текст абзаца<h4>еще один</h4>и еще текст\n"
+ "<h4>Документ 21</h4>\n"
+ "блао бла\n"
+ "<h4>Документ 21</h4>\n"
+ "вав\n"
+ "<h4>Документ 21\n"
+ "вавфвафва </h4>\n\n"
+ "<h4>[\\s\\S]*?<\\/h4>\\n?";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}