$re = '/^(?:03[19]|07[678])\d+$/m';
$str = '0311
0392
0763
0774
0785';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);