$re = '/\p{L}/m';
$str = 'Ørestads Boulevard 2B
Sankt Annæ Plads 32 5
Syriensvej 24 6 st th
Ørestads Boulevard 33
Sankt Annæ Plads 33
Øresundsvej 2B
Øresundsvej 2923B
Øresundsvej 292 st th, Amager
Øresundsvej 292334B';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);