$re = '/^[0-9]{1,6}(\.[0-9]{1,2})?$/m';
$str = '345543.99
032334.44
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);