$re = '/\w\d{2,4}(?:\w(?!\d))?/';
$str = 'F328AG560F33';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);