using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^\s+(?P<att_name>[^\s]+)\s+(?P<att_value>[^\s]+)(?P<att_body>\s{[\s\S]+?^\s})?)$";
string input = @"{
enabled 1
TARGET iqn.2012-05.local:mailbox.target.mccip001{
rel_tgt_id 1
IncomingUser ""user1234 secret123456""
enabled 0
MaxSessions 4
}
TARGET iqn.2012-05.local:mailbox.target.mccip002 {
rel_tgt_id 2
IncomingUser ""user1234 secret123456""
GROUP access_group{
LUN 0 dev2-0
LUN 1 dev2-1
LUN 2 dev2-2
LUN 3 dev2-3
LUN 4 dev2-4
LUN 5 dev2-5
LUN 6 dev2-6
LUN 7 dev2-7
LUN 8 dev2-8
LUN 9 dev2-9
INITIATOR iqn.1994-09.org.freebsd:*
}
enabled 1
MaxSessions 10
}
TARGET iqn.2012-05.local:mailbox.target.mccip003 {
rel_tgt_id 3
IncomingUser ""user1234 secret123456""
GROUP access_group {
LUN 0 dev3-0
LUN 1 dev3-1
INITIATOR iqn.1994-09.org.freebsd:*
}
enabled 1
MaxSessions 2
}
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}