const regex = /^(?:[$]|)[+-]?[0-9]{1,3}(?:[0-9]*(?:[.,][0-9]{2})?|(?:,[0-9]{3})*(?:\.[0-9]{1,2})?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[$]|)[+-]?[0-9]{1,3}(?:[0-9]*(?:[.,][0-9]{2})?|(?:,[0-9]{3})*(?:\\.[0-9]{1,2})?)$', 'gm')
const str = `123.00
678
10000000000000000000000000000000000000000
.01
123,123
12,2134
12,123,123,132,133.00
-1
+1
\$123.00123
123.123
123.23
abc
!^*&@^&*^#\$)&)@*#(@_)@_#++++(_@+#)&\$^%#@?<>>?>?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}