import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-?(?=\\d{1,15}(?:[.,]0+)?0*$|(?:(?=[,.\\d]{1,16}0*$)(?:\\d+[.,]\\d{1,2}$))).+$";
final String string = "// PASS\n"
+ "0\n"
+ "0.00\n"
+ "1\n"
+ "-1\n"
+ "1.23456789012345\n"
+ "10.2345678901234\n"
+ "12.3456789012345\n"
+ "-123.4\n"
+ "-12.34\n"
+ "-1,33\n"
+ "-1.33\n"
+ "-1.333\n"
+ "-123456789012345\n"
+ "-1234567890123450\n"
+ "-12345678901234.50\n"
+ "12345678901234.50\n"
+ "123456789012345.00\n\n"
+ "// FAIL\n"
+ "-1234567890123456\n"
+ "-12345678901234.56\n"
+ "12345678901234.56\n"
+ "123456789012345.60\n"
+ "1.234567890123456\n"
+ "12.34567890123456\n"
+ "123456789012340.6\n"
+ "123456789012300.67\n"
+ "123456789012300000000000.67\n"
+ "10000000000010000000001000010000000001.22";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}