const regex = /\|\s+\[(?P<domain>(?:[^\|]|\\\|)+)\]\((?P<url>https?:\/\/(?:www\.)?[^\)]+)\)\s+\|\s+(?P<cloudflare>(?:[^\|]|\\\|)+)\s+\|\s+(?P<country>(?:[^\|]|\\\|)+)\s+\|\s+(?P<isp>(?:[^\|]|\\\|)+)\s+\|\s+(?P<branch>(?:[^\|]|\\\|)+)\|/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\|\\s+\\[(?P<domain>(?:[^\\|]|\\\\\\|)+)\\]\\((?P<url>https?:\\\/\\\/(?:www\\.)?[^\\)]+)\\)\\s+\\|\\s+(?P<cloudflare>(?:[^\\|]|\\\\\\|)+)\\s+\\|\\s+(?P<country>(?:[^\\|]|\\\\\\|)+)\\s+\\|\\s+(?P<isp>(?:[^\\|]|\\\\\\|)+)\\s+\\|\\s+(?P<branch>(?:[^\\|]|\\\\\\|)+)\\|', 'gm')
const str = `| Link | Cloudflare | Country | ISP | Branch |
| -------- | ---------- | ----------- | ----- | ----- |
| [gh.akisblack.dev](https://gh.akisblack.dev) | No | Germany | OVHcloud | master |
| [gothub.esmailelbob.xyz](https://gothub.esmailelbob.xyz) | No | Canada | OVHcloud | master |
| [gothub.no-logs.com](https://gothub.no-logs.com/) | No | Sweden | Vultr | master |
| [gh.odyssey346.dev](https://gh.odyssey346.dev) | No | France | OVHcloud (Trolling Solutions) | master |
| [gh.phreedom.club](https://gh.phreedom.club) | No | Iceland | Flokinet | master |
| [gothub.projectsegfau.lt](https://gothub.projectsegfau.lt) | No | GeoDNS (Luxembourg/USA/India) | BuyVM/Digital Ocean/Airtel | master |
| [gh.riverside.rocks](https://gh.riverside.rocks) | No | USA | Comcast | master |
| [gh.fascinated.cc](https://gh.fascinated.cc) | Yes | Germany | Contabo | master |
| [gothub.lunar.icu](https://gothub.lunar.icu) | Yes | Germany | Unesty | master |
| [gothub.xbdm.fun](https://gothub.xbdm.fun) | Yes | Germany | Hetzner | master |
| [dev.gh.akisblack.dev](https://dev.gh.akisblack.dev) | No | Germany | OVHcloud | dev |
| [gh.creller.net](https://gh.creller.net) | No | Scotland | British Telecommunications PLC | dev |
| [gh.dev.odyssey346.dev](https://gh.dev.odyssey346.dev) | No | France | OVHcloud (Trolling Solutions) | dev |
| [gothub.dev.projectsegfau.lt](https://gothub.dev.projectsegfau.lt) | No | Luxembourg | BuyVM | dev |`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}