const regex = /(\d{4})(0{6,7}|\W+|\s+)(\W|)(\d{5,6})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{4})(0{6,7}|\\W+|\\s+)(\\W|)(\\d{5,6})', 'gm')
const str = `EREF+4222173235-0000005 SVWZ+RNr. 5198000000035463 RDat. 04.08.2022 KNr. 51029216 abzgl. 71,32 EUR Skonto BETON HOTLINE HANDELS-GMBH
EREF+KR80273316382022072121 311 SVWZ+506700000003316/ 2022.07.07 /SKONTO 2,16 STRABAG AG
SVWZ+KDNR 50315602, RNR 506 7000000033132 JOHANN DECHANT
EREF+KR80273316382022072121 316 SVWZ+506700000033442/ 2022.07.08 /SKONTO 39,90 STRABAG AG
EREF+KR57073492122022072143 335 SVWZ+5067/33177 / 2022.07.0 7 ED. ZUEBLIN AG
EREF+5067500001273722 MREF+2019506750008938100000 000278 CRED+DE86ZZZ00000012195 SVWZ+BELG 5067000000033228/20220721 2785.07 SKONTO 4.000
EREF+NOTPROVIDED SVWZ+KD-NR.: 50381903, RG 34022, SKONTO 6,58 EUR KAYMAK ESTRICHBAU GMBH
EREF+KR80270331532022072118 785 SVWZ+519832454 / 2022.06.24 STRABAG AG
EREF+NOTPROVIDED SVWZ+RE-NR.: 33960 ABEL ESTRICHE GMBH + CO.KG
EREF+NOTPROVIDED SVWZ+KD 500469634 RE5198-34173 ABWA+SVEN PETERBURS TRANSPORT GM SVEN PETERBURS TRANSPORT GM BH
EREF+REF2022072100000002 SVWZ+KD-NR. 50272457 RG. 519000000033592 / 12.07.2022 42,03 RG. 5198000000033409 / 08.07.2022 80,54 OTTO MUEHLHERR BAUGESELLSCH AFT MBH
EREF+NOTPROVIDED SVWZ+11.7.22 RENR 140921 2.21.7 1527/22 KDNR. 51748957 TIEFBAU SOMMERFELD GMBH
EREF+9458919 SVWZ+257346/63005131 R 5067 -33304 K 51053189 V 07.07.2022 STADT REGENSBURG
svwz+re-nr. 5067…34142 v. 20.7.22 hans wallesch gmbh
EREF+0000940800 SVWZ+/SDV/0000940800 22.7.2022 MHI BAUSTOFF GMBH SENEFELDE RSTR. 14
EREF+NOTPROVIDED SVWZ+RENR: 52940000000142168 ABWA+LAUSCH, THOMAS, STIEN LAUSCH THOMAS LAUSCH STIEN LAUSCH
EREF+ID324-20220722-081356- 002 SVWZ+E + T GMBH GOERLITZ 510298655294000000139722 11.07.2022 20,54 SKONTO 0,33 5294000000140368 12.07.2022 25,10 SKONTO 0,41 ABWA+E + T ERD
EREF+NOTPROVIDED SVWZ+RECHG.. 52940000143628 V. 20.07.2022 KUNDE 50547527 METALL-U-ZAUNBAU DRASCHANOW SKI GMBH
EREF+0000330267 SVWZ+RE.NR.5067000000032046 23.6.2022 RE.NR.50670O0000 032045 23.6.2022 RE.NR.5067 000000035283 29.7.2022 ROHRDORFER TRANSPORT
SVWZ+NR. 148216 50670000000 35134 SKONTO 158,37 RIEDEL AU GMBH CO
EREF+50042669 SVWZ+RE 5067000000033952 KD 50042669 EUR 145,75 SK 0,0 0/RE 506700000034278 KD 50 042669 EUR 13436,32 SK 351, 15 WADLE BAUUNTERNEHMUNG GMBH
EREF+0007007384 SVWZ+0905009623/SIEHE AVIS 0007007384VOM 08.08.2022 IMPLENIA SPEZIALTIEFBAU
EREF+5108220257140159364273 1 SVWZ+RENR: 5067000000035108 V. 29.7.22 KDNR: 50547693 PETER VEIGL
EREF+REF2022080800000012 SVWZ+KD.NR. 000000000000 RG. 35272 5. 752,46 ABZGL. SKONTO 172,57-BREITENEICHER GMBH
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}