$re = '/(?:[A-Z0-9]{6}-|[A-Z0-9]{5}--)[0-9]{3}[A-Z]{2}65[0-9A-F]{2}/m';
$str = '123456-789LM65F2
4EF789-012XY65A5
A2345--789AB65D0
23456--890JK65D0
123-12HASJDJKA
9898AASJD823';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);