using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"YOUR REGEX HERE";
string input = @"169.237.46.168 - - [26/Jan/2014:10:47:58 -0800] ""GET /stat141/Winter04/ HTTP/1.1"" 200 2585 ""http://anson.ucdavis.edu/courses/""
193.205.203.3 - - [2/Feb/2005:17:23:6 -0800] ""GET /stat141/Notes/dim.html HTTP/1.0"" 404 302 ""http://eeyore.ucdavis.edu/stat141/Notes/session.html""
169.237.46.240 - "" [3/Feb/2006:10:18:37 -0800] ""GET /stat141/homework/Solutions/hw1Sol.pdf HTTP/1.1""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}