$re = '/(?=[^\\\\]*$).*?\.sav/m';
$str = 'C:\\Users...\\Standard Loadflows Seq and Dyn PSSEv34 - 2019-02-20\\AutumnHi-20180531-183047-34-SystemNormal\\AutumnHi-20180531-183047-34-SystemNormal.sav
\'Users\\\\...\\\\Standard Loadflows Seq and Dyn PSSEv34 - 2019-02-20\\\\WinterLo-20180729-043047-34-SystemNormal\\\\WinterLo-20180729-043047-34-SystemNormal.sav was\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);