// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(?:(https?):\/\/)?(?:(?:www|m|api)\.)?(soundcloud\.com|snd\.sc)\/+([a-zA-Z0-9\-\.]+\/*[a-zA-Z0-9\-\.]*\/*[a-zA-Z0-9\-\.]*)").unwrap();
let string = "https://soundcloud.com/deejay-la-x
https://soundcloud.com/deejay-la-x/my-christmas-mix-with-tarmac
sdasdddd
https://soundcloud.com/golden-rose-428706194/drip-vol2
https://soundcloud.com/karyomusic/karyo-my-neck-lick-it?utm_source=clipboard&utm_medium=text&utm_campaign=social_sharing
https://soundcloud.com/rnjonesnc/sets/30-flights-of-elevation
https://on.soundcloud.com/5dTNx
<iframe width=\"100%\" height=\"300\" scrolling=\"no\" frameborder=\"no\" allow=\"autoplay\" src=\"https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/923619058&color=%23ff5500&auto_play=false&hide_related=false&show_comments=true&show_user=true&show_reposts=false&show_teaser=true&visual=true\"></iframe><div style=\"font-size: 10px; color: #cccccc;line-break: anywhere;word-break: normal;overflow: hidden;white-space: nowrap;text-overflow: ellipsis; font-family: Interstate,Lucida Grande,Lucida Sans Unicode,Lucida Sans,Garuda,Verdana,Tahoma,sans-serif;font-weight: 100;\"><a href=\"https://soundcloud.com/kaytranada\" title=\""KKAAYYTTRRAA"\" target=\"_blank\" style=\"color: #cccccc; text-decoration: none;\">"KKAAYYTTRRAA"</a> ยท <a href=\"https://soundcloud.com/kaytranada/love-is-stronger-than-pride-kaytra-edit\" title=\"LOVE IS STRONGER THAN PRIDE (KAYTRA EDIT)\" target=\"_blank\" style=\"color: #cccccc; text-decoration: none;\">LOVE IS STRONGER THAN PRIDE (KAYTRA EDIT)</a></div>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}