re = /(?:^|\s)(#[a-zA-Zа-яА-Я]+[,.!:?\s]*)(?=\s[a-zA-Zа-яА-Я])/
str = '#Yandex #Apple Chainlink выпустил новую платформу для разработчиков #Functions, которая предоставляет бесплатный доступ к готовым функциям оракулов, упрощая процесс создания децентрализованных приложений на #Blockchain #Chainlink #девелопмент'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end