const regex = /(?:\bSTART\b|(?!^)\G)\h+(?!END\b).*?\b(\w{3,})(?=.*?\bEND\b)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\bSTART\\b|(?!^)\\G)\\h+(?!END\\b).*?\\b(\\w{3,})(?=.*?\\bEND\\b)', 'gi')
const str = `START one two three ENDING END one two END would match one, two, END, one, two`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}