$re = '/^[0-9]{0,3}(?=-)[0-9-]{0,4}$/m';
$str = '123-123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);