import re
regex = re.compile(r".*?(CR)\s?(\d\d\d)\-?(\d\d\d\d)", flags=re.MULTILINE)
test_str = ("CR 722-2018\n"
"CR7222018\n"
"-CR 7222018")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")