$re = '/@(?!.+\..+:)/m';
$str = 'sddw@we.com:@defe@wefe@fee';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);