# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((<br\s*\/?>){2,2})"
test_str = ("sad sa \n"
"asd \n"
"<br> <br> <br/>\n"
"asdsd\n"
"as\n"
"da\n"
"sd\n\n"
"<br/>\n"
"<br/>\n"
"<br/>\n\n"
"<br/> <br/> <br/> <br/> <br/><br/><br/><br/>\n\n"
"<br/> <br/>\n"
"<br/><br/><br/>\n\n"
"asg hfhgfhg\n"
"dsadsaddddddddddddddd fgh fgh fa\n"
"sd\n"
"sad\n"
"as\n"
"sdvfdbvdfbdf df fgh dgh g hgf\n\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.